Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CLI sbin shortcuts
#11
risen, before version 1.3, I tried it in versions 1.1.1 and 1.2, Live, USB, not virtualized, in this time I had an vulnerable router in hands ,I sold, so, when doing an bruteforce with Reaver, using the standard command line, reaching 2,93 %
> > complete, I got an endless "could not open /dev/urandom" this in version 1.1.1 and 1.2, bully worked perfect, in version 1.3 I don't test Reaver again. In version 1.3, bruteforcing, you reach 100% with Reaver?

Note: Now I'm using TP, Live, Virtualized,
Reply
#12
I have, but only with one card using reaver in 1.3, the card I have with mt7601u chipset worked in this way paired with reaver. Other cards with known chipsets targeting same vulnerable router did not. I was not aware of the previous reaver bug but almost ever tp release has had a different reaver build version by default - 1.5.2, 1.6.2, 1.6.4, 1.6.5 or whatever the versioning was. Not saying that had anything to do with the previous bug but perhaps one of the previous reaver builds compiled odd with one of the libs or dependencies of the previous tp release.
Reply
#13
I have used this card and method using reaver directly from CLI as well as autopwner and airgeddon scripts. In all three cases reaver and this type of attack completed as well as generated successful results.
Reply
#14
in this case I used CLI, not scripts, with basic, or standard command, just to be sure, you reach 100% in live and usb, boot without virtualization? I know, you said "Live and Installed is samething, but I ask just to be sure, but may be it is an old Reaver bug as you said like this "https://github.com/ChristopherGlennCole/reaver-wps/issues/511", but in this case with 93.92%, Sad, oh shit
Reply
#15
Yes, LIVE or installed is identical image with the exception of tc-installer extension. Tp like tc preloads and runs from within system memory regardless. I achieved attack using "sudo reaver -i wlan1mon -e essid -b bssid" from CLI. As far as being a bug with previous reaver, could've been, may have been a compatibility issue with a lib used in that version release of TP. As far as tested, I've run and tested on live, install in VM and live on USB media.
Reply
#16
all right, sorry, I have an trouble with post edition, may be have some confusion with last message, so, have no issues with Reaver in 1.3
Reply
#17
The thing that makes trouble shooting exactly this is that things need to be considered, not just reaver unless a specific error or crash code is spit out. For instance, distance, device output strength, device, device chipset, system libs, router - even if known as vulnerable, etc, etc.
Reply
#18
So it's functional in 1.3 yes I think I misunderstood, what is the issue or question? I thought you were saying it did not or wasn't functioning correctly.
Reply
#19
I think which is all right, the issue "could not open /dev/urandom" from 1.1 and 1.2 is now in 1.3 fixed! Fine!

thank you,
Reply
#20
Lol ok, well good! That would be ideal from one release to the next or next after that, either fix Tp or include new builds of a previously broken tool. Thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)